Blog Details

image

Which Internet Browser Should I Use To Best View Account Access?

To access your account, use browser software that supports a security technology called Secure Sockets Layer (SSL). The following browsers and version numbers are compatible with the prudential.com website: Microsoft® Internet Explorer 8.0 (recommended) Mozilla Firefox 1.5 In addition to these browsers, you will need to ensure that the following settings are enabled on within your browser in order to use your online account. Enable SSL (v2) or SSL (v3) Accept cookies, or warn me before accepting a cookie Enable Java Script Finally, we recommend you upgrade your browser to the highest level of encryption available (a28-bit). Please keep in mind that 128-bit browser support is not currently available outside the United States.